Monthly Archives: enero 2016

Solucionar el error “Found 1 integrity violations” en Alfresco 5.0.2

Cuando se instala Alfresco 5.0.2 y 5.1.EA, si esta instalación recoge los parámetros para español, se produce un error como el siguiente:

 

Caused by: org.alfresco.repo.node.integrity.IntegrityException: 00270001 Found 1 integrity violations:

Invalid property value:

Node: workspace://SpacesStore/141296a2-92d5-4160-82ec-828421bd8a4a

Name: Rep. Dem.

Type: {http://www.alfresco.org/model/content/1.0}category

Property: {http://www.alfresco.org/model/content/1.0}name

 

Este error ya se resuelve en la incidencia https://issues.alfresco.com/jira/browse/ALF-21423 por Angel Borroy y lo que voy a explicar es, simplemente, como arreglarlo en el propio fichero WAR, de forma que, si instalamos de nuevo, no se produzca de nuevo el error.

 

Primero descomprimimos el fichero alfresco.war:

cd tomcat/webapps

mkdir fix

cp alfresco.war fix

cd fix

unzip alfresco.war

 

Descomprimimos el fichero alfresco-repository-5.0.x.x.jar (cambia las x por el número que tenga):

cd WEB-INF/lib

mkdir fix

cd fix

jar -xvf ../alfresco-repository-5.0.2.5.jar

 

Cambiamos el mensaje que falla en bootstrap-messages_es.properties:

vi alfresco/messages/bootstrap-messages_es.properties

[Buscar dentro de vi, p.e. /Rep\.\ Dem\.]

[Cambiar “Rep. Dem.” por “Rep\u00fablica”]

Nota: Se podría hacer de una vez sustituyendo en vi, pero eso os lo dejo a vosotros 😉

[Guardar con ESC+:wq]

 

Volvemos a crear el JAR (cuidado con los números de revisión), sobreescribimos el original y borramos este directorio:

jar cvf alfresco-repository-5.0.2.5.jar *

cp alfresco-repository-5.0.2.5.jar ../

cd ..

rm -rf fix

 

Volvemos a crear el WAR, creamos una copia del original, otra del nuevo, sustituimos el original y borramos el directorio de trabajo:

cd ../../

zip -r alfresco.war *

cd ..

cp alfresco.war alfresco.war-orig

cp fix/alfresco.war .

cp alfresco.war alfresco.war-fix

mv alfresco.war-orig ../../

mv alfresco.war-fix ../../

rm -rf fix

cd ../../

 

Reiniciamos el servicio de Alfresco y, si todo ha ido bien, arrancará sin problemas.

 

Nota: No olvidéis borrar previamente el despliegue (webapps/alfresco) así como el contenido del directorio work.

 

Eso es todo, solo me queda dar las gracias a Angel Borroy por su aportación en la resolución de este problema.

 

Más información:

https://forums.alfresco.com/es/forum/usu%C3%A1rio-alfresco/instalaci%C3%B3n/value-rep-dem-not-valid-file-name-10202015-1558

https://issues.alfresco.com/jira/browse/ALF-21423